LOADING

100%帮你解决,关于maven项目报:org.apache.maven.plugins:mavenresourcesplugin:2.6的解决办法,

–>

我创建项目的时候就遇到了这个问题 maven相关依赖包下载失败,或者明明有这个jar包,但还是报错。

百度了很多,也试过各种方法,更换过很多仓库中心 有默认的 阿里云的 都不行。

最后 我的解决办法,简单暴力,使用maven默认的setting.xml配置文件。

方法是:

1、下载一个apache-maven-3.6.3-bin.zip包  加压出来,

2、直接使用conf里面的setting.xml

3、修改setting.xml配置 设置成自己的仓库

4、设置eclipse配置maven仓库

5、Maven–>update project–>ok,  然后就出去吃个饭,等待maven的依赖jar包慢慢下载就ok了(半个小时下载完)

本文来源 互联网收集,文章内容系作者个人观点,不代表 本站 对观点赞同或支持。如需转载,请注明文章来源,如您发现有涉嫌抄袭侵权的内容,请联系本站核实处理。

© 版权声明

相关文章