旧版本Eclipse导入项目,提示“Target runtime Apache Tomcat v8.0 is not defined”

–>

旧版本Eclipse导入项目提示“Target runtime Apache Tomcat v8.0 is not defined”

  • 问题是:
  • 问题原因:
  • 解决办法:

问题是:

我在用luna版本的eclipse导入项目时提示Target runtime Apache Tomcat v8.0 is not defined。

问题原因:

我本地安装的tomcat是v8.5.45,当前旧版本不支持,最高只能支持到8.0版本;

解决办法:

1.要么更新当前版本的server,要么用掩耳盗铃的办法将tomcat的版本号降低,此处我由于更新过慢,所以选择了后者,具体操作方法为:

打开tomcat\lib目录——》用解压工具打开catalina.jar——》然后找到catalina.jar\org\apache\catalina\util目录下的ServerInfo.properties文件,用编辑器打开,将第16行的“server.info=Apache Tomcat/8.5.45”,这里的数字改为8.0.45,保存并关闭。

此处解决了低版本的eclipse无法识别高版本的tomcat的问题。

有兴趣了解前种办法的,可以参考这篇博客:【eclipse】不支持Tomcat8和Tomcat8.5或者更高版本
2.解决“Target runtime Apache Tomcat v8.0 is not defined”问题:
右键工程根目录,选择properties——》Targeted Runtimes,
此处有两种情况:第一种是选择当前的本地tomcat即可,然后确认并关闭

图片来源下面的博客链接:Eclipse导入项目,提示“Target runtime Apache Tomcat v8.0 is not defined”,解决方法。

但我本人尝试后发现并不行,所以如果有人尝试过同样解决不了问题,可以考虑第二种:
在此处选择new——》选择tomcatV8.0——》next——》选择你的tomcat目录,然后finish

本文来源 互联网收集,文章内容系作者个人观点,不代表 本站 对观点赞同或支持。如需转载,请注明文章来源,如您发现有涉嫌抄袭侵权的内容,请联系本站核实处理。

© 版权声明

相关文章