LOADING

解决tomcat 启动 An incompatible version [1.2.14] of the APR based Apache Tomcat Native library 错误

–>

解决tomcat 启动 An incompatible version [1.2.14] of the APR based Apache Tomcat Native library 错误(懵逼了大半上午的错误)

原因:是因为这个配置文件的版本太低, 要去官网找到1.2.14版本
http://archive.apache.org/dist/tomcat/tomcat-connectors/native/1.2.14/binaries/

注意:记得下后缀是bin的不是src,以后如何变更版本的话也是一样的方法
然后下载解压出来里面是有64位版本和32位版本的,根据你的需要版本复制到你的tomcat/bin和jdk/bin下,重新运行项目可以了。
我刚开始用来64位出现了这个错误
C:\Program Files (x86)\Java\jdk1.8.0_25\bin\tcnative-1.dll: Can’t load AMD 64-bit .dll on a IA 32-bit platform
谷歌翻译是:
C:\ Program Files(x86)\ Java \ jdk1.8.0_25 \ bin \ tcnative-1.dll:无法在IA 32位平台上加载AMD 64位.dll出现这个错误换一个重复刚才的操作就可以 了。
我看网上说有改C:\Windows\System32 就好

但是我是改了两个地方的

1、替换tomcat,bin中的文件

2、jdk,bin中的文件

也有人说要改
1、替换tomcat,bin中的文件

2、jdk,bin中的文件

3、jre,bin中的文件

本文来源 互联网收集,文章内容系作者个人观点,不代表 本站 对观点赞同或支持。如需转载,请注明文章来源,如您发现有涉嫌抄袭侵权的内容,请联系本站核实处理。

© 版权声明