LOADING STUFF...

An incompatible version [1.2.10] of the APR based Apache Tomcat Native library is installed….

–>

An incompatible version [1.2.10] of the APR based Apache Tomcat Native library is installed, while Tomcat requires version [1.2.24]

IntellJ IDEA起一个Spring Boo项目,启动后出现两个ERROR日志。
看提示是:1.2.10 的不满足了,需要去下载1.2.24版本。
需要替换一个tcnative-1.dll

去Apache Tomcat官方地址下载。
地址是:http://archive.apache.org/dist/tomcat/tomcat-connectors/native/

找到适合的版本

我需要的是1.2.24的

下载后打开 外边这个 tcnative-1.dll 是32位的,64位的 tcnative-1.dll 文件在 x64 目录下

然后将文件拷贝到jdk的bin目录中或者是jre的bin目录中(或者将文件拷贝到C:\Windows\System32)即可

 

 

本文来源 互联网收集,文章内容系作者个人观点,不代表 本站 对观点赞同或支持。如需转载,请注明文章来源,如您发现有涉嫌抄袭侵权的内容,请联系本站核实处理。

© 版权声明

相关文章